Bezpečnostní problém - zastaralá verze knihovny PHPMailer v TNG 11.1.2

Instalace na lokálním PC, instalace na webovém hostingu, správné zobrazení češtiny, apod.
Uživatelský avatar
michal
Příspěvky: 473
Registrován: 06 čer 2013 21:37
Bydliště: Hostinné
Kontaktovat uživatele:

Bezpečnostní problém - zastaralá verze knihovny PHPMailer v TNG 11.1.2

Příspěvekod michal » 24 úno 2018 15:54

Poslední verze TNG (11.1.2) obsahuje zastaralou verzi knihovny PHPMailer. Použitá verze obsahuje zásadní bezpečnostní problém starý několik let. Řešením by byl upgrade knihovny PHPMailer alespoň na verzi 5.2.22.
Podle informací programátora TNG bude novou verzi knihovny obsahovat nová verze TNG 12, kterou plánuje vydat někdy na jaře letošního roku.

Možnost aktualizace knihovny PHPMailer před vydáním nové verze TNG je následující:
1) Přejděte na stránku https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.22
2) Klikněte na "Source code (zip)" a uložte stahovaný soubor PHPMailer-5.2.22.zip.
3) Po stažení soubor PHPMailer-5.2.22.zip rozbalte a vyhledejte zde soubory class.phpmailer.php a class.smtp.php.
4) Tyto soubory nakopírujte do programové složky TNG a nahraďte jimi původní soubory.

Zpět na “Instalace a konfigurace”

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 1 host